web analytics
Categories
failure to return to battery Gallery of Guns Grand Power lubrication MAC P11

A Revisit – Grand Power P11

I’d not visited the range since June 2017 so I packed up a bag yesterday evening and took the Grand Power P11, just to see if the gun would fare any better with the fails to return to battery.  As well, someone on Youtube mentioned that I was riding the slide.  I’ll admit that I took personal offense to that, because I know for a fact that I’m not riding the slide on any gun, much less the P11 (if I were, I would be having issues with more than just the P11).  And, another very well known Youtuber has been having the exact same issues (that would be MAC – Military Arms Channel) with his P1.

I bought ammo at the range, 100 rounds of American Eagle 115-gr FMJ.  I’ve ammo at home but wanted to try ammo that I know most of my guns will run without issue.  I don’t think I’ve ever had any issues with American Eagle in any of my firearms.

I ensured the P11 was lubed before I left home.  It has been clean and unfired since May 2017.  The lube I used is Motul 5w20.  It’s a tad heavy, but I also used a fine coat of CLP on the typical places where the P11 needs lube.

The handgun ate all the rounds without failing to return to battery…all but one.  It failed on round 94.  I was disappointed.  100 rounds isn’t much…it couldn’t get through 100 rounds without failing.

Another Youtuber insists that I call Eagle Imports and have them look into the issue.  I may do that but I may just call Gallery of Guns (that’s where I bought it from…they’ve lifetime guarantees of their firearms).  Whichever will be the path of least resistance will be good.

The range visit made me miss carrying the P11.  It is and has always been accurate and comfortable in my hands.  I miss carrying it, but I just can’t stand the failures to return to battery.

I’ll open it up later today to see how dirty the gun is.  I’m sure I’ll see a ton of carbon (even with me using just a bit of oil) where the barrel rides in the frame…that’s the only place that can get dirty enough to cause battery issues.  It makes me wonder if I should stop putting lube in that location.

UPDATE:

 Here are pictures of the dirty areas of the gun.  There is carbon that has coated the oil and it was causing friction that is preventing the barrel from rotating properly, which is causing the failures to return to battery.  If CLP doesn’t work, or even regular 5w20 motor oil, WTF is going to be good enough to prevent this sort of thing?  Maybe something IS out of spec…